コミュニティ掲示板

汎用データベースのインポート機能のバグ?

投稿日時: 2018/09/19 たっちー

汎用データベースに関して謎の現象に悩まされています。
この症状の検証の為に、新規にNetCommons-3.2.0をインストールして試しました。
汎用データベースを作成し、レコードを1件登録します。
このデータは、ログインしていない人でも閲覧できることが確認されます。
再びログインしてこのデータベースの内容をエクスポートし、その内容をテキストエディタでちょっとだけ変更しインポートします。
するとログインした人の画面ではレコード2件表示されるのですが、ログインしていない人の表示では最初の1件のままなのです。
つまり、インポートしたデータはログインしていない人には表示されないのです。
さらにインポートしたデータは、エクスポートの対象にもならないです。
これって何かのバグでしょうか?

Re: 汎用データベースのインポート機能のバグ?

投稿日時: 2018/09/19 OSWS永原

こんにちは。
永原です。

これ、汎用データベースのインポートのバグですね。
githubでも報告は上がってたと思います。

インポートしたレコードが一時保存的な扱いになっているようです。
データベースのレコードのフラグ(テーブルは忘れた)を更新してあげれば、表示できるようになります。

汎用データベースに関して謎の現象に悩まされています。
この症状の検証の為に、新規にNetCommons-3.2.0をインストールして試しました。
汎用データベースを作成し、レコードを1件登録します。
このデータは、ログインしていない人でも閲覧できることが確認されます。
再びログインしてこのデータベースの内容をエクスポートし、その内容をテキストエディタでちょっとだけ変更しインポートします。
するとログインした人の画面ではレコード2件表示されるのですが、ログインしていない人の表示では最初の1件のままなのです。
つまり、インポートしたデータはログインしていない人には表示されないのです。
さらにインポートしたデータは、エクスポートの対象にもならないです。
これって何かのバグでしょうか?

Re3: 汎用データベースのインポート機能のバグ?

投稿日時: 05/09 onaka

永原様、タッチ―様
初めまして、onakaです。今後、お教え頂きたいことが溜まっていまして、今後何度かお尋ねすることがあろうかと思いますが、どうぞよろしくお願いします。
今回、教え頂きたいことは、タッチーさんと同じ症状で、タッチさんは無事解決されたようですが、私は解決できませんでした。

MySQLで
update multidatabase_contents set is_active=1;

のやり方が分からなくて、

所定のデータベースを選択し、表示タブの中でmultidatabase_contents 行を選択、次に、is_activeのセルに表示された0をクリックして1に変更し、その後、1が表示されることを確認しましたが、インポート時の問題点が解決できていません。
更新方法が間違っているのでしょうか?SQLタブの中で処理しないといけないのでしょうか?
実は、ちょっと試してみましたがエラーが発生し、、先に進めていません。
因みに、is_latestが0ですが、これが問題でしょうか?

以上、宜しくお願いします。

MySQLで
update multidatabase_contents set is_active=1;
としたら、解決しました。(全データをフラグ更新)
助かりました。ありがとうございました!

Re4: 汎用データベースのインポート機能のバグ?

投稿日時: 05/16 OSWS永原

こんにちは。
永原と申します。

> MySQLで
> update multidatabase_contents set is_active=1;
> のやり方が分からなくて、

データベースをコマンドで操作したり、phpmyadminで操作したりって、できます?
データベースを更新して、データを直接、変更してくださいね。
ということを指しているのです。

> 因みに、is_latestが0ですが、これが問題でしょうか?

すみません、データを確認していないので、すぐ思い出せないのですが、怪しいフラグがあれば、試してみるのが良いと思いますよ。
でも、is_latestは、最終データかどうかの判断な気がするので、多分違うと思います。
画面から登録したデータがうまく表示されているなら、表示されているものとそうでないものを比較されるのも、良いかもしれないですね。

以上、失礼いたします。



永原様、タッチ―様
初めまして、onakaです。今後、お教え頂きたいことが溜まっていまして、今後何度かお尋ねすることがあろうかと思いますが、どうぞよろしくお願いします。
今回、教え頂きたいことは、タッチーさんと同じ症状で、タッチさんは無事解決されたようですが、私は解決できませんでした。

MySQLで
update multidatabase_contents set is_active=1;

のやり方が分からなくて、

所定のデータベースを選択し、表示タブの中でmultidatabase_contents 行を選択、次に、is_activeのセルに表示された0をクリックして1に変更し、その後、1が表示されることを確認しましたが、インポート時の問題点が解決できていません。
更新方法が間違っているのでしょうか?SQLタブの中で処理しないといけないのでしょうか?
実は、ちょっと試してみましたがエラーが発生し、、先に進めていません。
因みに、is_latestが0ですが、これが問題でしょうか?

以上、宜しくお願いします。

MySQLで
update multidatabase_contents set is_active=1;
としたら、解決しました。(全データをフラグ更新)
助かりました。ありがとうございました!